Create New Tag
C50_image_1452187619 Walter White Quote
7/6/2017 9:26 PM

Getting to the throttle body and taking the cables out was fairly easy. When I put the new one back in, the throttle now barely moves at all. I've tried numerous things to make it work, but I've had zero success. Anyone out there have any tips on what I should try next?

C50_rhonda_1498294167 GaryC1 Quote
7/7/2017 2:08 AM

Have you routed the cable the exact same way as it came out? Also compare the adjustment at both ends of the cable to make sure it is set the same as the old cable and finally make sure it is guided correctly on the throttle body and isn't snagged or caught.

All obvious things I have mentioned so sorry if you have checked them but other than that I can't think of anything. Many be worth re-fitting your old cable to see if that works again and it could be an issue with the new cable.

Good luck

C50_image_1452187619 Walter White Quote
7/7/2017 2:52 AM
Walter White wrote:

Getting to the throttle ...more

GaryC1 wrote:

Have you routed the cable ...more

Thank you for the reply! Unfortunately I have tried all of those things. I routed it the exact way I took it out too. But I'll try and take it out and then hook it all back up, crossing my fingers it works because this has been one of the most annoying this I've dealt with lol.

C50_rhonda_1498294167 GaryC1 Quote
7/7/2017 5:12 AM

Yeah it's a weird one for sure! Does the throttle flap move ok when you move it by hand? And also when you say the throttle barely moves do you mean the actual grip moves very little then jams or stops? If you were able to throw up a couple pictures of the throttle body area then that would be helpful too! I have had some issues before that were solved by some embarassingly simple solutions haha

C50_image_1452187619 Walter White Quote
7/7/2017 1:55 PM
GaryC1 wrote:

Yeah it's a weird one for ...more

When the cables aren't attached to the throttle, they move freely and smoothly, but once I put the cables into the throttle housing, it's stiff as hell when I turn the throttle. I've tried three different throttle tubes and have had the same result. I plan on working on it extensively this coming Monday. If I can't get it to work I'll snap some pics and post them.

C50_hatfall_1450633513 Falcon Quote
7/7/2017 3:02 PM

Make sure your cables aren't cross-referenced. You have a push-pull cable system and they definitely need to be attached to correct side of your throttle body.
If your throttle won't open at all, this may be the issue.

C50_image_1452187619 Walter White Quote
7/7/2017 4:42 PM
Falcon wrote:

Make sure your cables ...more

To be completely honest, that never even entered my mind. If I did that I'm gonna feel like such a dummy haha. Thank you for the advice! I'll definitely be checking it.

C50_trey_c_1439133231 NeedMoto Quote
7/7/2017 11:06 PM

Cables cross referenced will be your issue as Falcon mentions^^^

Good luck with fix

C50_image_1452187619 Walter White Quote
7/11/2017 3:59 PM
Falcon wrote:

Make sure your cables ...more

Falcon you were absolutely spot on. I feel pretty silly having screwed up a simple task. But thank you for the info.

Post a Reply

Cool Wink Smile Tongue Laughing Shocked Sick Angry Blink Sad Unsure Kissing Woohoo Grinning Silly Pinch Sideways Whistling Evil Dizzy Blush Cheerful Huh Dry

See All Deals ยป